多边对等交换
多边对等交换 (MLPE) 通过路由服务器自动实现开放网络之间的对等连接,从而使新的对等网络和现有参与者受益。
MLPE包括:
- 支持 IPv4 和 IPv6 单播路由
- 每个位置都配备冗余路由服务器
- 使用互联网路由注册表 (IRR) 表实现对虚假路由和参与者通告的过滤。
- 透明地移除 MLPE ASN 跳转
- BGP MD5 认证
- 基于 BGP 社区的路由通告和 AS 预置过滤
多边对等互连的工作原理
- 双边对等互连和多边对等互连共享相同的 VLAN 和 IP。
- 对等互联客户与 Equinix 冗余 MLPE 服务器建立 eBGP 会话。
- 您与 MLPE 服务器交换路由。
- MLPE 服务器使用互联网路由注册数据库 (IRRDB) 和资源公钥基础设施 (RPKI) 来过滤这些路由。

申请MLPE参与
申请参与MLPE:
-
输入贵组织的实际设置。您可以选择使用MD5的安全会话,并选择自由文本BOX以满足特殊请求。

-
每个区域都将展开,以帮助您选择要与所列网点对等的端口IP地址。允许多个网点。

-
点击提交MLPE请求。
要申请和管理您的MLPE参与,请登录客户门户网站并点击“申请MLPE参与”。
更多详情,请单击MLPE信息。
MLPE 路由服务器 BGP 社区
所有Equinix多方对等互联交换(MLPE)路由服务器都允许参与者使用边界网关协议(BGP)社区对其路由的出站通知进行更多控制。您可以允许或拒绝所有路由,但两者的路由除外,您还可以允许预先提交ASN最多3次。
**提示:**将BGP社区与MLPE服务配合使用并非强制性要求。但是,大型对等方通常使用它,以避免通过MLPE从其他大型对等方获取流量。
以下部分包括社区信息和Cisco配置示例。
信息和对等操作社区(由 MLPE 路由服务器发送给对等方)
| 社区 | 描述 | 注释 |
|---|---|---|
| 24115:65012 | RPKI 有效 | |
| 24115:65023 | RPKI 未知 | |
| 65535:65281 | 禁止出口 | RFC1997 |
| 65535:65282 | 无广告 | RFC1997 |
| 24115:1000:1 | RPKI 有效 | |
| 24115:1000:2 | RPKI 未知 | |
| 24115:1000:3 | RPKI 未检查 | |
| 24115:1001:1 | IRRDB 有效 | IRRDB 中存在前缀(ASN 或 AS-SET) |
| 24115:1001:2 | IRRDB 未检查 | 静态前缀列表 |
| 24115:1002:RSN | 路由服务器追踪器 | 路由服务器标记 |
| 24115:1003:MS | 同行往返时间 | 毫秒 |
| 24115:1004:ASN | 传入的对等ASN |
运营社区(由 MLPE 路由服务器从参与者处接收)
| 社区 | 描述 | 注释 |
|---|---|---|
| 24115:65281-65283 | 禁止出口 | RFC1997 |
| 65535:65281-65283 | 禁止出口 | RFC1997 |
| 24115:24115 | 默认开放策略 | 向所有同行宣布 |
| 0:24115 | 默认关闭策略 | 不要告诉任何同伴。 |
| 24115:24115 0:ASN | 默认打开,ASN 除外 | 除ASN外,向所有同行发布公告 |
| 0:24115 24115:ASN | 默认关闭策略,ASN 除外 | 除ASN外,请勿向任何其他同行发布此消息。 |
| 65535:0 | 优雅关机 | RFC8326 |
| 65535:666 | RTBH 前缀 | RFC7999 |
| 65501:24115 | 在前缀前添加 24115 1x | 将 AS24115 添加到路径 |
| 65501:ASN | 在邻居ASN之前添加1x | 在路径前添加对等 AS |
| 65502:ASN | 在邻居 ASN 前添加 2x | 在路径前添加对等 AS |
| 65503:ASN | 在邻居 ASN 前添加 3x | 在路径前添加对等 AS |
| 65001:40 | 本地偏好 40 | |
| 65001:50 | 本地偏好 50 | |
| 65001:140 | 本地偏好 140 | |
| 65001:150 | 本地偏好 150 | |
| RT:0:ASN | 默认开放(ASN 除外) | 除ASN外,向所有同行发布公告 |
| RT:24115:ASN | 允许导出到 ASN | 仅向ASN发布 |
| RT:65501:ASN | 在邻居 ASN 前添加对等 ASN 1 次 | |
| RT:65502:ASN | 将对等 ASN 添加到邻居 ASN 2 次 | |
| RT:65503:ASN | 在邻居 ASN 前面添加对等 ASN 3 次 | |
| 24115:1:24115 | 默认开放策略 | 向所有同行宣布 |
| 24115:0:24115 | 默认关闭策略 | 不要告诉任何同伴。 |
| 24115:0:ASN | 禁止出口至ASN | 请勿向邻居 ASN 投放广告 |
| 24115:1:ASN | 允许导出到 ASN | 向邻居 ASN 通告 |
| 24115:2:MS | 禁止向 MS 以上的邻居导出 | 以 5 毫秒为增量,从 5 毫秒到 200 毫秒。 |
| 24115:101:ASN | 在邻居ASN之前添加1x | 在路径前添加对等 AS |
| 24115:102:ASN | 在邻居 ASN 前添加 2x | 在路径前添加对等 AS |
| 24115:103:ASN | 在邻居 ASN 前添加 3x | 在路径前添加对等 AS |
| 24115:111:MS | 延迟高于毫秒时,加 1 倍。 | 以 5 毫秒为增量,从 5 毫秒到 200 毫秒。 |
| 24115:112:MS | 延迟高于毫秒时,需加 2 倍。 | 以 5 毫秒为增量,从 5 毫秒到 200 毫秒。 |
| 24115:113:MS | 延迟高于毫秒时,需加 3 倍前缀。 | 以 5 毫秒为增量,从 5 毫秒到 200 毫秒。 |
已筛选的信息社区(仅在 IX Portal 的 Looking Glass 中显示)
| 社区 | 描述 | 注释 |
|---|---|---|
| 24115:1101:1 | 前缀长度过长 | IPv4长度上限:24,IPv6:64 |
| 24115:1101:2 | 前缀长度过短 | 最小长度IPv4:24,IPv6:64 (仅限RTBH) |
| 24115:1101:3 | 博贡前缀 | Cymru IPv4 和 IPv6 bogons |
| 24115:1101:4 | 路径中的 Bogon ASN | 路径中的 Bogon ASN |
| 24115:1101:5 | AS 路径过长 | IPv4:24,IPv6:64 |
| 24115:1101:6 | AS 路径过短 | IPv4:0,IPv6:0 |
| 24115:1101:7 | 无效的第一个ASN | 路径中的第一个 AS 不是对等 AS |
| 24115:1101:8 | 无效的下一跳地址 | 下一跳地址不是对等地址 |
| 24115:1101:9 | 未找到 IRRDB 前缀 | 在对等 ASN 或 AS-SET 中未找到前缀。 |
| 24115:1101:13 | RPKI 无效 | 无效的 ROA、源 AS 和/或前缀长度 |
| 24115:1101:20 | AS 环 | 路径中的 AS 循环 |
| 24115:1102:1 | 广告同行拒绝前缀 | 广告同行政策不包括接收方同行 |
使用 BGP 团体的示例配置
默认打开,但 AS10、AS20 和 AS30 除外
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-open community on outbound and
# set communities to restrict annoucnements from AS10, 20 and 30.
route-map eqixsg-out permit 10
set community 24115:24115 0:10 0:20 0:30
# reject routes received from AS 10, 20 and 30
route-map eqixsg-in deny 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^30_
默认关闭,AS10、AS20 和 AS100030 除外
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-closed community on outbound and
# set communities on announcements to AS10, AS20, and AS100030
route-map eqixsg-out permit 10
set community 0:24115 24115:10 24115:20 24115:30
set extcommunity rt 0:100030
# accept routes from AS10, AS20, and AS100030
route-map eqixsg-in permit 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^100030_
本地路线覆盖所有人,国际路线仅限往返 AS10 和 AS100020。
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# announce local routes with default open community
route-map eqixsg-out permit 10
match community 40:4000 # local routes
set community 24115:24115
# announce international routes with default closed community
# and community to announce to AS10 and AS100020 only
route-map eqixsg-out permit 20
match community 40:5000 # international routes
set community 0:24115 24115:10
set extcommunity rt 24115:100020
在 AS10 前添加 AS40 1x,在 AS20 前添加 AS40 2x,在 AS100030 前添加 AS40 3x
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
route-map eqixsg-out permit 10
set community 65501:10 65502:20
set extcommunity rt 65503:100030
遥控触发黑洞
# signals to MLPE route-servers to set next-hop as Black Hole host for configured network/host
router bgp 40
network 1.1.1.1 mask 255.255.255.255
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map RM-RTBH-OUT out
neighbor 202.79.197.126 send-community
route-map RM-RTBH-OUT permit 10
match ip address prefix-list PL-RTBH-OUT
set community 65535:666
ip prefix-list PL-RTBH-OUT seq 10 permit 1.1.1.1/32
ip route 1.1.1.1 255.255.255.255 Null0