跳转到主要内容

配置BGP

Fabric Cloud Router 使用 BGP 路由协议,并支持多种功能,使用户能够管理流量路由方式以支持复杂的拓扑。

在 Fabric 云路由器上创建连接后,您可以从“连接清单”中配置其路由。选择要配置的连接。

在“路由详情”选项卡上,单击“配置路由”。

Initial Routing Configuration Screenshot

如果您要更新或编辑以前的配置,请在“路由详细信息”选项卡上,单击“直接路由详细信息”或“BGP 路由详细信息”部分中的“编辑”。

Updating Routing Details Screenshot

路线详情 - 直达​

选择要提供的子网类型:输入我自己的 IPv4 地址。

请输入 Equinix 端的 IPv4 地址,使用 CIDR 表示法。/30 即可,但也允许使用 /28 和 /29。如果您使用 IPv6,也请输入 IPv6 地址,同样使用 CIDR 表示法。

路由详细信息 - BGP​

要启用对其他 BGP 路由的管理,请选择启用边界网关协议 (BGP)。

IPv4 和 IPv6 对等寻址​

Fabric Cloud Router(FCR) 支持 IPv4 和 IPv6 寻址。每种地址类型都可以独立配置,也可以同时配置(双栈)。通过 FCR 创建的每个虚拟连接都需要为连接上使用的每个 IP 协议版本配置本地 (FCR) 和远程对等 IP 地址。在大多数情况下,您可以定义要使用的 BGP 对等互连子网,除非远程对等设备(例如Google Cloud)需要特定寻址。

输入对等 IPv4 主机地址和(可选)对等 IPv6 主机地址。

Peer IP Addresses Fields Screenshot

MD5认证​

Cloud Router 支持使用 RFC2385 中规定的 MD5 身份验证,它通过要求参与的 BGP 对等体具有匹配的 MD5 身份验证密钥,为 BGP 提供了额外的安全层。

Fabric Cloud Router MD5 身份验证支持最多 80 个 ASCII 字符(未散列)。

如果您使用 BGP 身份验证,请输入共享密钥。确保该密钥在Fabric Cloud Router端和连接的远端都匹配。

Authentication Field Screenshot

IPv4/v6 接收的最大路由数(最大前缀限制)​

云端路由器支持配置从特定对等体接收的最大路由数量。这允许您配置在重置 BGP 会话之前允许对等体向云端路由器通告的最大路由数量。

警告

如果对等体通告的连接数超过了配置的限制,云端路由器会重置 BGP 会话 5 分钟,然后再重新建立会话。此外,在会话建立后配置或更新最大限制也会触发 BGP 会话重置。

输入最大前缀限制。

Max Prefix Limit Fields Screenshot

允许的值 - 介于 1 和云路由器套餐 IPv4/v6 路由配额之间。

默认值 – 云路由器套餐路由配额限制。如果您未配置此值,则默认值为云路由器的 IPv4/6 配额。有关云路由器套餐的更多信息,请参阅服务套餐。

对等 ASN​

远程 BGP 对等体的自治系统编号 (ASN) 提供三层连接。云路由器同时支持已注册(公共)ASN 和私有 ASN 范围。云路由器在每个 Fabric都会区中使用唯一的 Equinix 注册 ASN (../index.md#locations-and-asns),以避免与私有 ASN 发生潜在冲突。同一都会区内的云路由器始终使用相同的已注册 ASN,目前不支持用户配置的 ASN。

Cloud Router 允许使用 2 字节或 4 字节 ASN(1-4294967294),但以下列出的号码除外。

ASNPurpose
Special purpose numbers:
0Reserved by RFC7607
112Used by the AS112 project RFC7534
23456AS_TRANS; reserved by RFC6793
64496–64511Reserved for documentation by RFC5398
65535Reserved by RFC7300
65536–65551Reserved for documentation by RFC5398
4294967295Reserved by RFC7300
IANA reserved numbers:
65552-131071Reserved by IANA
Equinix-reserved numbers:
64600, 4200000000–42000000002

输入您的对等 ASN。

Peer ASN Field Screenshot

AS Path Prepend​

云端路由器支持出站 AS 路径前置功能,允许您设置 AS 路径前置的数量。如果设置的值大于 0,云端路由器会根据您选择的前置值将其自身的 ASN 添加到 AS 路径中。使用前置功能会增加 AS 路径的长度。这向 BGP 对等体发出信号,表明特定连接的优先级可能较低,因为 BGP 路由优先级所依赖的参数之一是 BGP 对等体之间的自治系统 (AS) 数量。较长的 AS 路径通常优先级较低,除非其他 BGP 操作的优先级高于 AS 路径长度。

支持的 FCR AS 路径值:禁用、1、3、5 默认:禁用(不会添加前缀)

要启用,请从下拉菜单中选择 AS 路径值。

AS-path Prepend Drop-down Screenshot

AS Override​

Cloud Router 支持用户启用的 AS 覆盖,它会覆盖 FCR 通告的 AS 路径中找到的 BGP 对等 ASN 的一个或多个实例。

当使用一个或多个 Fabric 云路由器(连接到 IP-WAN 网络的多个云路由器)通过相同的自治系统编号 (ASN) 来互连网络时,可以使用 AS 覆盖来禁用默认的 eBGP 环路预防机制。

示例:当用户在多个城市(例如达拉斯和阿什本(华盛顿特区))拥有云路由器,并通过 IP-WAN 互连时,可能需要在 FCR 上启用 AS 覆盖。该用户还连接到云提供商(例如 Oracle、Azure 或 Google),该提供商在两个位置的所有云区域都使用单个全局 ASN。用户可能希望其云区域之间的跨区域流量通过云路由器和 IP-WAN 路由,而不是通过云提供商的网络。在这种情况下,可以在每个云提供商的 FCR 连接上启用 AS 覆盖,从而允许云区域之间的流量,因为通告前缀的 AS 路径将不包含云提供商的源 ASN。

支持的 AS 覆盖设置:禁用、启用

默认:禁用

要启用,请选择“启用 AS 覆盖”。

AS Override Checkbox Screenshot

多出口鉴别器​

云端路由器支持用户为每个连接配置入站和出站多出口鉴别符 (MED)。默认使用 MED 参数需要相邻 AS 之间有多个连接。

MED 参数是可选的,允许您向对等体建议其向源 AS 发送流量时应使用的首选连接。MED 也可以在本地应用于已接收(入站)前缀,以影响哪个连接可用于向相邻 AS 发送流量。配置 MED 时,数值较低的值优先于数值较高的值。

  • 入站 – 用户应用于连接的 MED 值,以影响本地路由决策,使发送到相邻 AS 的流量优先选择此连接而不是其他连接。
  • 出站 – 向相邻 AS 通告的 MED 值,用于建议发送到此 AS 的流量的首选连接。

云路由器支持的 MED 值:1 – 4294967295

输入您的入站和出站 MED 值。

MED Fields Screenshot

双向转发检测 (BFD)​

云端路由器支持为每个虚拟连接启用用户启用的 BFD,这有助于缩短在重新收敛过程中检测和传播 BGP 路由变化所需的时间,包括最大限度地减少故障转移事件造成的中断。您可以配置云端路由器向 BGP 对等体通告的 BFD TX 间隔。

云路由器支持的 BFD TX 间隔:100 – 999(毫秒)

默认值:BFD 已启用 = 否

BFD 倍数:3 倍(此值不可由用户配置。)

如果您想使用双向转发检测 (BFD),请选择“启用 BFD”并设置合适的毫秒间隔。连接两端的 BFD 间隔必须匹配。

BFD Option and Configuration Screenshot

应用更改​

更新完路由详情后,点击“应用更改”。如果连接状态为“接口配置待定”,则会更新为“已配置”。

这个页面对您有帮助吗?