Troca de peering multi-lateral
A Troca de Pares Multilateral (MLPE) automatiza o intercâmbio de pares entre redes abertas por meio de servidores de roteamento, beneficiando tanto as novas redes de intercâmbio quanto os participantes existentes.
MLPE inclui:
- Suporte para rotas unicast IPv4 e IPv6
- Servidores de roteamento redundantes em cada local.
- Filtros para rotas falsas e anúncios de participantes implementados usando tabelas do Registro de Roteamento da Internet (IRR).
- Remove de forma transparente o salto ASN do MLPE.
- Autenticação BGP MD5
- Filtragem baseada na comunidade BGP para anúncios de rotas e pré-pendência de AS.
Funcionamento do Peering Multilateral
- A mesma VLAN e o mesmo endereço IP são compartilhados entre o peering bilateral e o peering multilateral.
- O cliente de peering estabelece sessões eBGP com servidores MLPE redundantes da Equinix.
- Você troca rotas com os servidores MLPE.
- O servidor MLPE filtra essas rotas usando o Banco de Dados de Registro de Roteamento da Internet (IRRDB) e a Infraestrutura de Chave Pública de Recursos (RPKI).

Solicitar participação no MLPE
Para solicitar a participação no MLPE:
-
Informe AS CONFIGURAÇÕES da sua organização. Você tem a opção de selecionar uma sessão segura com MD5 e um BOX de texto livre para solicitações especiais.

-
Cada região é expandida para ajudar você a selecionar o endereço IP da porta para emparelhar com os locais listados. São permitidos vários locais.

-
Clique em Enviar Solicitação MLPE.
Para solicitar e gerenciar sua participação no MLPE, faça login no Portal do Cliente e clique em Solicitar participação no MLPE.
Para obter mais detalhes, clique em Informações do MLPE .
Comunidades BGP do servidor de rota MLPE
Todos os servidores de rota de Troca de peering lateral (MLPE) da Equinix permitem que os participantes tenham mais controle sobre os anúncios de saída de suas rotas usando as Comunidades de Protocolo de Gateway de Fronteira (BGP). Você pode permitir ou negar todas as rotas, com exceções para ambas, e pode permitir a antecipação do seu ASN até 3 vezes.
Dica: O uso das Comunidades BGP com o serviço MLPE não é obrigatório. No entanto, geralmente é usado por pares grandes para evitar levar o tráfego de outros pares grandes pela MLPE.
As seções a seguir incluem informações da comunidade e exemplos de configuração da Cisco.
Comunidades informativas e operacionais entre pares (enviadas pelo servidor de roteamento MLPE para o par)
| Comunidade | Descrição | Notas |
|---|---|---|
| 24115:65012 | RPKI Válido | |
| 24115:65023 | RPKI desconhecido | |
| 65535:65281 | Sem exportação | RFC1997 |
| 65535:65282 | Sem anúncios | RFC1997 |
| 24115:1000:1 | RPKI Válido | |
| 24115:1000:2 | RPKI desconhecido | |
| 24115:1000:3 | RPKI não verificado | |
| 24115:1001:1 | IRRDB válido | O prefixo existe no IRRDB (ASN ou AS-SET). |
| 24115:1001:2 | IRRDB não verificado | Lista de prefixos estáticos |
| 24115:1002:RSN | Rastreador de Servidor de Rota | Marcador do servidor de rotas |
| 24115:1003:MS | Tempo de ida e volta do mesmo par | Milissegundos |
| 24115:1004:ASN | ASN de pares de entrada |
Comunidades operacionais (recebidas pelo servidor de roteamento MLPE do participante)
| Comunidade | Descrição | Notas |
|---|---|---|
| 24115:65281-65283 | Sem exportação | RFC1997 |
| 65535:65281-65283 | Sem exportação | RFC1997 |
| 24115:24115 | Política de abertura padrão | Anuncie a todos os colegas |
| 0:24115 | Política padrão fechada | Não anuncie a nenhum colega. |
| 24115:24115 0:ASN | Aberto por padrão, exceto para ASN | Anuncie a todos os colegas, exceto à ASN. |
| 0:24115 24115:ASN | Política padrão fechada, exceto para ASN | Não anuncie a nenhum colega, exceto à ASN. |
| 65535:0 | Encerramento suave | RFC8326 |
| 65535:666 | Prefixo RTBH | RFC7999 |
| 65501:24115 | Adicione 24115 1 vez ao prefixo. | Adicione AS24115 ao caminho. |
| 65501:ASN | Prefixar 1x no ASN vizinho | Adicionar AS de par ao caminho |
| 65502:ASN | Adicionar 2x ao ASN vizinho | Adicionar AS de par ao caminho |
| 65503:ASN | Adicionar 3 vezes ao ASN vizinho | Adicionar AS de par ao caminho |
| 65001:40 | Preferência Local 40 | |
| 65001:50 | Preferência Local 50 | |
| 65001:140 | Preferência Local 140 | |
| 65001:150 | Preferência Local 150 | |
| RT:0:ASN | Aberto por padrão, exceto para ASN | Anuncie a todos os colegas, exceto à ASN. |
| RT:24115:ASN | Permitir exportação para ASN | Anunciar somente para a ASN |
| RT:65501:ASN | Adicionar ASN do par 1x ao ASN do vizinho | |
| RT:65502:ASN | Adicionar ASN do par 2x ao ASN do vizinho | |
| RT:65503:ASN | Adicionar ASN do par 3 vezes ao ASN do vizinho | |
| 24115:1:24115 | Política de abertura padrão | Anuncie a todos os colegas |
| 24115:0:24115 | Política padrão fechada | Não anuncie a nenhum colega. |
| 24115:0:ASN | Não é permitida a exportação para ASN. | Não anuncie para vizinhos ASN |
| 24115:1:ASN | Permitir exportação para ASN | Anuncie para o vizinho ASN |
| 24115:2:MS | Não é permitida a exportação para países vizinhos acima do Estado Livre. | Incremento de 5ms, de 5ms a 200ms |
| 24115:101:ASN | Prefixar 1x no ASN vizinho | Adicionar AS de par ao caminho |
| 24115:102:ASN | Adicionar 2x ao ASN vizinho | Adicionar AS de par ao caminho |
| 24115:103:ASN | Adicionar 3 vezes ao ASN vizinho | Adicionar AS de par ao caminho |
| 24115:111:MS | Adicione 1x para latência acima de MS | Incremento de 5ms, de 5ms a 200ms |
| 24115:112:MS | Adicione 2x para latência acima de MS | Incremento de 5ms, de 5ms a 200ms |
| 24115:113:MS | Adicione 3x para latência acima de MS | Incremento de 5ms, de 5ms a 200ms |
Comunidades informativas filtradas (exibidas apenas no Looking Glass do Portal IX)
| Comunidade | Descrição | Notas |
|---|---|---|
| 24115:1101:1 | Prefixo com comprimento muito longo | IPv4 de comprimento máximo: 24, IPv6: 64 |
| 24115:1101:2 | Prefixo com comprimento muito curto | IPv4 de comprimento mínimo: 24, IPv6: 64 (somente RTBH) |
| 24115:1101:3 | Prefixo Bogon | Cymru IPv4 e IPv6 bogons |
| 24115:1101:4 | Bogon ASN em Path | Bogon ASN em Path |
| 24115:1101:5 | Caminho AS muito longo | IPv4: 24, IPv6: 64 |
| 24115:1101:6 | Caminho muito curto | IPv4: 0, IPv6: 0 |
| 24115:1101:7 | ASN inicial inválido | Primeiro AS no caminho, não AS par. |
| 24115:1101:8 | Endereço de próximo salto inválido | O endereço do próximo salto não é o endereço do par. |
| 24115:1101:9 | Prefixo IRRDB não encontrado | O prefixo não foi encontrado no ASN ou AS-SET do par. |
| 24115:1101:13 | RPKI inválido | ROA, AS de origem e/ou comprimento de prefixo inválidos |
| 24115:1101:20 | Loop AS | Loop AS no caminho |
| 24115:1102:1 | Publicidade Peer recusa Prefixo | A Política de Pares de Publicidade exclui Pares Destinatários. |
Exemplos de configurações usando comunidades BGP
Aberto por padrão, exceto com AS10, AS20 e AS30.
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-open community on outbound and
# set communities to restrict annoucnements from AS10, 20 and 30.
route-map eqixsg-out permit 10
set community 24115:24115 0:10 0:20 0:30
# reject routes received from AS 10, 20 and 30
route-map eqixsg-in deny 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^30_
Padrão fechado, exceto AS10, AS20 e AS100030
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-closed community on outbound and
# set communities on announcements to AS10, AS20, and AS100030
route-map eqixsg-out permit 10
set community 0:24115 24115:10 24115:20 24115:30
set extcommunity rt 0:100030
# accept routes from AS10, AS20, and AS100030
route-map eqixsg-in permit 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^100030_
Rotas locais para todos, rotas internacionais apenas de/para AS10 e AS100020.
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# announce local routes with default open community
route-map eqixsg-out permit 10
match community 40:4000 # local routes
set community 24115:24115
# announce international routes with default closed community
# and community to announce to AS10 and AS100020 only
route-map eqixsg-out permit 20
match community 40:5000 # international routes
set community 0:24115 24115:10
set extcommunity rt 24115:100020
Adicione AS40 1x ao AS10, 2x ao AS20 e 3x ao AS100030.
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
route-map eqixsg-out permit 10
set community 65501:10 65502:20
set extcommunity rt 65503:100030
Buraco negro acionado remotamente
# signals to MLPE route-servers to set next-hop as Black Hole host for configured network/host
router bgp 40
network 1.1.1.1 mask 255.255.255.255
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map RM-RTBH-OUT out
neighbor 202.79.197.126 send-community
route-map RM-RTBH-OUT permit 10
match ip address prefix-list PL-RTBH-OUT
set community 65535:666
ip prefix-list PL-RTBH-OUT seq 10 permit 1.1.1.1/32
ip route 1.1.1.1 255.255.255.255 Null0