マルチラテラルピアリングエクスチェンジ
マルチラテラルピアリングエクスチェンジ(MLPE)は、ルートサーバーを通じてオープンネットワーク間のピアリングを自動化し、新しいピアリングネットワークと既存の参加者に利益をもたらします。
MLPE には以下が含まれます:
- IPv4およびIPv6ユニキャストルートのサポート
- 各拠点のルートサーバーを冗長化
- IRR(Internet Routing Registry)テーブルを利用した偽経路参加者広告のフィルタリング機能
- MLPE ASN ホップを透過的に削除
- BGP MD5認証
- ルートアナウンスとASプリペンディングのためのBGPコミュニティベースのフィルタリング
マルチラテラルピアリングの仕組み
- バイラテラル・ピアリングとマルチラテラル・ピアリングでは、同じVLANとIPが共有されます。
- ピアリングカスタマーは、Equinixの冗長MLPEサーバーとeBGPセッションを確立します。
- MLPE サーバとルートを交換します。
- MLPE サーバは、インターネットルーティングレジストリデータベース(IRRDB)とリソース公開鍵基盤(RPKI) を使用して、これらのルートをフィルタリングします。

MLPEへの参加をリクエスト
MLPEへの参加要請
-
組織のASセットを入力します。MD5とのセキュアなセッションと、特別なリクエストに対応するフリーテキストBOXを選択するオプションがあります。

-
各地域が拡張され、リストされた拠点とピアリングするポートIPアドレスを選択できるようになりました。複数の拠点が許可されています。

-
MLPE リクエストの送信」をクリックしてください。
MLPEへの参加をリクエストおよび管理するには、カスタマーポータルにサインインし、「MLPEへの参加をリクエスト」をクリックします。
詳細については、MLPE情報をクリックしてください。
MLPE ルートサーバ BGP コミュニティ
すべてのEquinixマルチラテラルピアリングエクスチェンジ(MLPE)ルートサーバを使用すると、参加者はボーダーゲートウェイプロトコル(BGP)コミュニティを使用して、ルートの送信アナウンスをより細かく制御できます。すべてのルートを許可または拒否できます(両方のルートを例外として)。また、ASNのプリペンディングを最大3回許可できます。
**ヒント:**MLPEサービスでBGPコミュニティを使用することは必須ではありません。ただし、通常は、MLPEを介して他の大きなピアからのトラフィックを取らないために、大規模なピアで使用されます。
以下のセクションには、コミュニティ情報と Cisco の設定例が含まれています。
情報コミュニティおよびピア運用コミュニティ(MLPE ルートサーバからピアへ送信されます)
| コミュニティ | 説明 | メモ |
|---|---|---|
| 24115:65012 | RPKI有効 | |
| 24115:65023 | RPKI不明 | |
| 65535:65281 | 輸出禁止 | RFC1997 |
| 65535:65282 | 広告なし | RFC1997 |
| 24115:1000:1 | RPKI有効 | |
| 24115:1000:2 | RPKI不明 | |
| 24115:1000:3 | RPKIがチェックされていません | |
| 24115:1001:1 | IRRDB 有効 | IRRDBにプレフィックスが存在(ASNまたはAS-SET) |
| 24115:1001:2 | IRRDB 未確認 | 静的プレフィックスリスト |
| 24115:1002:RSN | ルートサーバートレーサー | ルートサーバーマーカー |
| 24115:1003:MS | ピアラウンドトリップタイム | ミリ秒 |
| 24115:1004:ASN | 受信ピアASN |
運営コミュニティ(MLPE ルートサーバが参加者から受信)
| コミュニティ | 説明 | メモ |
|---|---|---|
| 24115:65281-65283 | 輸出禁止 | RFC1997 |
| 65535:65281-65283 | 輸出禁止 | RFC1997 |
| 24115:24115 | デフォルトのオープンポリシー | すべてのピアに発表 |
| 0:24115 | デフォルトのクローズドポリシー | どのピアにも発表しないでください |
| 24115:24115 0:ASN | ASN以外のデフォルトオープン | ASNを除くすべてのピアにアナウンス |
| 0:24115 24115:ASN | ASNを除くデフォルトのクローズドポリシー | ASN以外のピアにはアナウンスしません。 |
| 65535:0 | グレースフルシャットダウン | RFC8326 |
| 65535:666 | RTBH プレフィックス | RFC7999 |
| 65501:24115 | プレフィックスに24115 1xを付加 | AS24115をパスに追加 |
| 65501:ASN | 1xをネイバーASNに追加 | ピアASをパスにプリペンド |
| 65502:ASN | ネイバーASNへの2xプリペンド | ピアASをパスにプリペンド |
| 65503:ASN | ネイバーASNへの3xプリペンド | ピアASをパスにプリペンド |
| 65001:40 | ローカル優先40 | |
| 65001:50 | ローカル優先50 | |
| 65001:140 | ローカル優先140 | |
| 65001:150 | ローカル・プリファレンス150 | |
| RT:0:ASN | ASN以外のデフォルト・オープン | ASNを除くすべてのピアにアナウンス |
| RT:24115:ASN | ASNへのエクスポートを許可 | ASNのみに発表 |
| RT:65501:ASN | ピアASN 1xをネイバーASNにプリペンド | |
| RT:65502:ASN | ピアASN 2xをネイバーASNにプリペンド | |
| RT:65503:ASN | ピアASN 3xをネイバーASNにプリペンド | |
| 24115:1:24115 | デフォルトのオープンポリシー | すべてのピアに発表 |
| 24115:0:24115 | デフォルトのクローズドポリシー | どのピアにも発表しないでください |
| 24115:0:ASN | ASNへのエクスポートなし | ネイバーASNへの広告の禁止 |
| 24115:1:ASN | ASNへのエクスポートを許可 | ネイバーASNへのアドバタイズ |
| 24115:2:MS | MS以上の隣国への輸出禁止 | 5msから200msまで5ms刻み |
| 24115:101:ASN | 1xをネイバーASNに追加 | ピアASをパスにプリペンド |
| 24115:102:ASN | ネイバーASNへの2xプリペンド | ピアASをパスにプリペンド |
| 24115:103:ASN | ネイバーASNへの3xプリペンド | ピアASをパスにプリペンド |
| 24115:111:MS | MS以上の遅延には1xを付加 | 5msから200msまで5ms刻み |
| 24115:112:MS | MS以上の遅延には2倍を前置 | 5msから200msまで5ms刻み |
| 24115:113:MS | MS以上のレイテンシーには3倍を加算 | 5msから200msまで5ms刻み |
フィルタリングされた情報コミュニティ(IXポータルのルッキンググラスにのみ表示されます)
| コミュニティ | 説明 | メモ |
|---|---|---|
| 24115:1101:1 | プレフィックスの長さが長すぎます | IPv4の最大長:24、IPV6:64 |
| 24115:1101:2 | プレフィックスの長さが短すぎます | 最小長IPv4: 24、IPV6:64 (RTBHのみ) |
| 24115:1101:3 | ボゴン接頭辞 | Cymru IPv4およびIPv6ボゴン |
| 24115:1101:4 | パスのボゴンASN | パスのボゴンASN |
| 24115:1101:5 | ASパスが長すぎる | IPv4:24、IPV6:64 |
| 24115:1101:6 | ASパスが短すぎる | IPv4:0、IPV6:0 |
| 24115:1101:7 | 無効な最初のASN | ピアのASではなくパスの最初のAS |
| 24115:1101:8 | 無効なネクストホップアドレス | ネクストホップアドレスがピアアドレスではありません |
| 24115:1101:9 | IRRDB プレフィックスが見つかりません | ピアASNまたはAS-SETに接頭辞が見つかりませんでした。 |
| 24115:1101:13 | RPKIが無効です | 無効なROA、オリジンAS、プレフィックス長 |
| 24115:1101:20 | ASループ | パスのASループ |
| 24115:1102:1 | 広告ピアがプレフィックスを辞退 | 広告ピアポリシーは受領ピアを除く |
BGPコミュニティを使用した設定例
デフォルトはオープン(AS10、AS20、AS30を除く
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-open community on outbound and
# set communities to restrict annoucnements from AS10, 20 and 30.
route-map eqixsg-out permit 10
set community 24115:24115 0:10 0:20 0:30
# reject routes received from AS 10, 20 and 30
route-map eqixsg-in deny 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^30_
デフォルトクローズ(AS10、AS20、AS100030を除く
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-closed community on outbound and
# set communities on announcements to AS10, AS20, and AS100030
route-map eqixsg-out permit 10
set community 0:24115 24115:10 24115:20 24115:30
set extcommunity rt 0:100030
# accept routes from AS10, AS20, and AS100030
route-map eqixsg-in permit 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^100030_
AS10およびAS100020を発着する国際線のみ。
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# announce local routes with default open community
route-map eqixsg-out permit 10
match community 40:4000 # local routes
set community 24115:24115
# announce international routes with default closed community
# and community to announce to AS10 and AS100020 only
route-map eqixsg-out permit 20
match community 40:5000 # international routes
set community 0:24115 24115:10
set extcommunity rt 24115:100020
AS40をAS10に1倍、AS20に2倍、AS100030に3倍プリペンド
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
route-map eqixsg-out permit 10
set community 65501:10 65502:20
set extcommunity rt 65503:100030
リモートトリガーブラックホール
# signals to MLPE route-servers to set next-hop as Black Hole host for configured network/host
router bgp 40
network 1.1.1.1 mask 255.255.255.255
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map RM-RTBH-OUT out
neighbor 202.79.197.126 send-community
route-map RM-RTBH-OUT permit 10
match ip address prefix-list PL-RTBH-OUT
set community 65535:666
ip prefix-list PL-RTBH-OUT seq 10 permit 1.1.1.1/32
ip route 1.1.1.1 255.255.255.255 Null0