Échange de peering multi-latéral
L'échange de peering multilatéral (MLPE) automatise le pairage entre les réseaux ouverts grâce à des serveurs de routage qui profitent aux nouveaux réseaux d'appariement et aux participants existants.
MLPE comprend:
- Prise en charge des routes unicast IPv4 et IPv6
- Serveurs de routage redondants à chaque emplacement
- Filtres pour les faux itinéraires et les annonces de participants mis en œuvre à l'aide des tables du registre de routage Internet (IRR).
- Supprime de manière transparente le saut MLPE ASN
- Authentification BGP MD5
- Filtrage BGP communautaire pour les annonces de route et l'ajout de préfixes AS
Fonctionnement du pairage multilatéral
- Le même VLAN et la même adresse IP sont partagés entre l'appairage bilatéral et l'appairage multilatéral.
- Le client du peering établit des sessions eBGP avec les serveurs MLPE redondants d'Equinix.
- Vous échangez des routes avec les serveurs MLPE.
- Le serveur MLPE filtre ces routes à l'aide de la base de données du registre de routage Internet (IRRDB) et de l'infrastructure à clé publique des ressources (RPKI).

Demande de participation au MLPE
Pour demander la participation au MLPE:
-
Saisissez L'ÉTAT défini de votre organisation. Vous avez la possibilité de sélectionner une session sécurisée avec MD5 et un BOX en texte libre pour les demandes spéciales.

-
Chaque région est développée pour vous aider à sélectionner l'adresse IP du port à associer aux emplacements répertoriés. Plusieurs sites sont autorisés.

-
Cliquez sur « Soumettre une demande MLPE ».
Pour demander et gérer votre participation MLPE, connectez-vous au Portail client et cliquez sur demander une participation MLPE.
Pour plus de détails, cliquez sur MLPE information.
Communautés BGP du serveur de routage MLPE
Tous les serveurs de routage MLPE (échange d'appairage multi-latéral) Equinix permettent aux participants d'avoir plus de contrôle sur les annonces sortantes de leurs routes à l'aide des communautés BGP (protocole de passerelle frontière). Vous pouvez autoriser ou refuser toutes les routes, avec des exceptions pour les deux, et vous pouvez autoriser la mise en attente de votre ASN jusqu'à 3 fois.
Conseil : L’utilisation des communautés BGP avec le service MLPE n’est pas obligatoire. Cependant, il est généralement utilisé par les grands pairs pour éviter de prendre le trafic d'autres grands pairs sur MLPE.
Les sections suivantes incluent des informations sur la communauté et des exemples de configuration Cisco.
Communautés d'information et d'opérations entre pairs (envoyées par le serveur de routage MLPE au pair)
| Communauté | Description | Remarques |
|---|---|---|
| 24115:65012 | RPKI valide | |
| 24115:65023 | RPKI inconnu | |
| 65535:65281 | Aucune exportation | RFC1997 |
| 65535:65282 | Pas de publicité | RFC1997 |
| 24115:1000:1 | RPKI valide | |
| 24115:1000:2 | RPKI inconnu | |
| 24115:1000:3 | RPKI non vérifié | |
| 24115:1001:1 | IRRDB valide | Le préfixe existe dans IRRDB (ASN ou AS-SET) |
| 24115:1001:2 | IRRDB non vérifié | Liste de préfixes statiques |
| 24115 :1002 :RSN | Traceur de serveur de route | Marqueur de serveur routier |
| 24115 :1003 :MS | Temps d'aller-retour entre pairs | Millisecondes |
| 24115 :1004 :ASN | ASN pair entrant |
Communautés opérationnelles (reçues par le serveur de routage MLPE du participant)
| Communauté | Description | Remarques |
|---|---|---|
| 24115:65281-65283 | Aucune exportation | RFC1997 |
| 65535:65281-65283 | Aucune exportation | RFC1997 |
| 24115:24115 | Politique d'ouverture par défaut | Annoncez-le à tous vos collègues |
| 0:24115 | Politique de fermeture par défaut | N'en parlez à aucun de vos collègues. |
| 24115 :24115 0 :ASN | Ouverture par défaut, sauf pour ASN | Annoncez-le à tous vos pairs, sauf à l'ASN. |
| 0 :24115 24115 :ASN | Politique de fermeture par défaut, sauf pour les ASN | Ne l'annoncez pas à aucun collègue, sauf à ASN. |
| 65535:0 | Arrêt en douceur | RFC8326 |
| 65535:666 | Préfixe RTBH | RFC7999 |
| 65501:24115 | Ajouter 24 115 1 fois au préfixe | Ajouter AS24115 au début du sentier |
| 65501 :ASN | Ajoutez 1x au préfixe ASN du voisin | Ajouter l'AS du pair au chemin |
| 65502 :ASN | Ajouter 2x au nom d'utilisateur voisin | Ajouter l'AS du pair au chemin |
| 65503 :ASN | Ajouter 3 fois au nom de l'ASN voisin | Ajouter l'AS du pair au chemin |
| 65001:40 | Préférence locale 40 | |
| 65001:50 | Préférence locale 50 | |
| 65001:140 | Préférence locale 140 | |
| 65001:150 | Préférence locale 150 | |
| RT:0:ASN | Ouverture par défaut, sauf pour ASN | Annoncez-le à tous vos pairs, sauf à l'ASN. |
| RT :24115 :Asn | Autoriser l'exportation vers ASN | Annoncer uniquement à ASN |
| RT :65501 :Asn | Ajouter l'ASN du pair une fois à l'ASN du voisin | |
| RT:65502:ASN | Ajouter l'ASN du pair 2 fois au préfixe de l'ASN du voisin | |
| RT :65503 :Asn | Ajouter l'ASN du pair 3 fois au préfixe de l'ASN du voisin | |
| 24115:1:24115 | Politique d'ouverture par défaut | Annoncez-le à tous vos collègues |
| 24115:0:24115 | Politique de fermeture par défaut | N'en parlez à aucun de vos collègues. |
| 24115 :0 :ASN | Aucune exportation vers ASN | Ne pas faire de publicité auprès du voisin ASN |
| 24115 :1 :ASN | Autoriser l'exportation vers ASN | Annoncer à l'ASN voisin |
| 24115 :2 :MS | Aucune exportation vers les voisins au-dessus de MS | Incrément de 5 ms, de 5 ms à 200 ms |
| 24115 :101 :ASN | Ajoutez 1x au préfixe ASN du voisin | Ajouter l'AS du pair au chemin |
| 24115 :102 :ASN | Ajouter 2x au nom d'utilisateur voisin | Ajouter l'AS du pair au chemin |
| 24115 :103 :ASN | Ajouter 3 fois au nom de l'ASN voisin | Ajouter l'AS du pair au chemin |
| 24115 :111 :MS | Ajoutez 1x pour une latence supérieure à ms. | Incrément de 5 ms, de 5 ms à 200 ms |
| 24115 :112 :MS | Ajoutez 2x pour une latence supérieure à ms. | Incrément de 5 ms, de 5 ms à 200 ms |
| 24115 :113 :MS | Ajoutez 3x pour une latence supérieure à ms. | Incrément de 5 ms, de 5 ms à 200 ms |
Communautés d'information filtrées (affichées uniquement dans Looking Glass du portail IX)
| Communauté | Description | Remarques |
|---|---|---|
| 24115:1101:1 | Préfixe trop long | Longueur maximale IPv4 : 24, IPv6 : 64 |
| 24115:1101:2 | Préfixe trop court | Longueur minimale IPv4 : 24, IPv6 : 64 (RTBH uniquement) |
| 24115:1101:3 | Préfixe Bogon | Cymru IPv4 et IPv6 bogons |
| 24115:1101:4 | Bogon ASN dans Path | Bogon ASN dans Path |
| 24115:1101:5 | Chemin AS trop long | IPv4 : 24, IPv6 : 64 |
| 24115:1101:6 | Le chemin de l'AS est trop court | IPv4 : 0, IPv6 : 0 |
| 24115:1101:7 | Premier ASN invalide | Premier AS du chemin, pas un homologue AS |
| 24115:1101:8 | Adresse du prochain saut invalide | L'adresse du prochain saut n'est pas une adresse homologue. |
| 24115:1101:9 | Préfixe IRRDB introuvable | Le préfixe est introuvable dans l'ASN du pair ou l'AS-SET. |
| 24115:1101:13 | RPKI non valide | ROA, AS d'origine et/ou longueur de préfixe invalides |
| 24115:1101:20 | Boucle AS | Boucle AS dans le chemin |
| 24115:1102:1 | Publicité par les pairs décline le préfixe | La politique de publicité entre pairs exclut le destinataire pair |
Exemples de configurations utilisant des communautés BGP
Ouverture par défaut, sauf avec AS10, AS20 et AS30
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-open community on outbound and
# set communities to restrict annoucnements from AS10, 20 and 30.
route-map eqixsg-out permit 10
set community 24115:24115 0:10 0:20 0:30
# reject routes received from AS 10, 20 and 30
route-map eqixsg-in deny 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^30_
Fermé par défaut, sauf AS10, AS20 et AS100030
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-closed community on outbound and
# set communities on announcements to AS10, AS20, and AS100030
route-map eqixsg-out permit 10
set community 0:24115 24115:10 24115:20 24115:30
set extcommunity rt 0:100030
# accept routes from AS10, AS20, and AS100030
route-map eqixsg-in permit 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^100030_
Liaisons locales pour tous, liaisons internationales seulement vers/depuis AS10 et AS100020
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# announce local routes with default open community
route-map eqixsg-out permit 10
match community 40:4000 # local routes
set community 24115:24115
# announce international routes with default closed community
# and community to announce to AS10 and AS100020 only
route-map eqixsg-out permit 20
match community 40:5000 # international routes
set community 0:24115 24115:10
set extcommunity rt 24115:100020
Ajouter AS40 1x à AS10, 2x à AS20 et 3x à AS100030
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
route-map eqixsg-out permit 10
set community 65501:10 65502:20
set extcommunity rt 65503:100030
Trou noir déclenché à distance
# signals to MLPE route-servers to set next-hop as Black Hole host for configured network/host
router bgp 40
network 1.1.1.1 mask 255.255.255.255
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map RM-RTBH-OUT out
neighbor 202.79.197.126 send-community
route-map RM-RTBH-OUT permit 10
match ip address prefix-list PL-RTBH-OUT
set community 65535:666
ip prefix-list PL-RTBH-OUT seq 10 permit 1.1.1.1/32
ip route 1.1.1.1 255.255.255.255 Null0