Intercambio de emparejamiento multilateral
Multi-Lateral Peering Exchange (MLPE) automatiza el peering entre redes abiertas mediante servidores de rutas que benefician a las nuevas redes de peering y a los participantes existentes.
MLPE incluye:
- Compatibilidad con rutas unidifusión IPv4 e IPv6
- Servidores de ruta redundantes en cada ubicación
- Filtros para rutas falsas y anuncios de participantes implementados mediante tablas del Registro de enrutamiento de Internet (IRR)
- Elimina de forma transparente el salto ASN MLPE
- Autenticación MD5 de BGP
- Filtrado basado en comunidades BGP para anuncios de rutas y AS pre-pendientes
Funcionamiento del peering multilateral
- Se comparte la misma VLAN e IP entre el peering bilateral y el peering multilateral.
- El cliente de peering establece sesiones eBGP con servidores MLPE redundantes de Equinix.
- Usted intercambia rutas con los servidores MLPE.
- El servidor MLPE filtra estas rutas utilizando Internet Routing Registry Database (IRRDB) y Resource Public Key Infrastructure (RPKI).

Solicitar participación en MLPE
Para solicitar la participación de MLPE:
-
Introduzca el conjunto de su organización. Tiene la opción de seleccionar una sesión segura con MD5 y un BOX de texto gratuito para peticiones especiales.

-
Cada región se expande para ayudarle a seleccionar la dirección IP del puerto para emparejar con las ubicaciones indicadas. Se permiten varias ubicaciones.

-
Haga clic en Enviar solicitud de MLPE.
Para solicitar y gestionar su participación en MLPE, inicie sesión en el portal del cliente y haga clic en Solicitar participación en MLPE.
Para obtener más información, haga clic en Información de MLPE .
Servidor de rutas MLPE Comunidades BGP
Todos los servidores de rutas de intercambio de emparejamiento multilateral (MLPE) de Equinix permiten a los participantes tener más control sobre los anuncios salientes de sus rutas utilizando las comunidades del protocolo de puerta de enlace fronteriza (BGP). Puede permitir o denegar todas las rutas, con excepciones para ambas, y puede permitir la prepensión de su ASN hasta 3 veces.
Consejo: El uso de comunidades de BGP con el servicio MLPE no es obligatorio. Sin embargo, normalmente lo usan los pares grandes para evitar tomar tráfico de otros pares grandes a través de MLPE.
Las siguientes secciones incluyen información comunitaria y ejemplos de configuración de Cisco.
Comunidades informativas y operativas entre pares (enviadas por el servidor de rutas MLPE a los pares)
| Comunidad | Descripción | Notas |
|---|---|---|
| 24115:65012 | RPKI válido | |
| 24115:65023 | RPKI desconocido | |
| 65535:65281 | No Exportar | RFC1997 |
| 65535:65282 | Sin publicidad | RFC1997 |
| 24115:1000:1 | RPKI válido | |
| 24115:1000:2 | RPKI desconocido | |
| 24115:1000:3 | RPKI no marcado | |
| 24115:1001:1 | IRRDB válido | El prefijo existe en IRRDB (ASN o AS-SET) |
| 24115:1001:2 | IRRDB No comprobado | Lista de prefijos estáticos |
| 24115:1002:RSN | Rastreador de servidor de rutas | Marcador de servidor de ruta |
| 24115:1003:MS | Tiempo de ida y vuelta entre pares | Milisegundos |
| 24115:1004:ASN | ASN par entrante |
Comunidades operativas (recibidas por el servidor de rutas MLPE del participante)
| Comunidad | Descripción | Notas |
|---|---|---|
| 24115:65281-65283 | No Exportar | RFC1997 |
| 65535:65281-65283 | No Exportar | RFC1997 |
| 24115:24115 | Política de apertura por defecto | Anunciar a todos los pares |
| 0:24115 | Política cerrada por defecto | No anunciar a ningún compañero |
| 24115:24115 0:ASN | Abierto por defecto excepto para ASN | Anunciar a todos los pares excepto ASN |
| 0:24115 24115:ASN | Política cerrada por defecto excepto para ASN | No anunciar a ningún par excepto ASN |
| 65535:0 | Apagado Gracioso | RFC8326 |
| 65535:666 | Prefijo RTBH | RFC7999 |
| 65501:24115 | Anteponer 24115 1x al prefijo | Añadir AS24115 a la ruta |
| 65501:ASN | Anteponer 1x al ASN vecino | Anteponer AS par a ruta |
| 65502:ASN | Anteponer 2x a ASN vecino | Anteponer AS par a ruta |
| 65503:ASN | Anteponer 3x al ASN vecino | Anteponer AS par a ruta |
| 65001:40 | Preferencia local 40 | |
| 65001:50 | Preferencia local 50 | |
| 65001:140 | Preferencia local 140 | |
| 65001:150 | Preferencia local 150 | |
| RT:0:ASN | Abierto por defecto Excepto para ASN | Anunciar a todos los pares excepto ASN |
| RT:24115:ASN | Permitir la exportación a ASN | Anunciar sólo a ASN |
| RT:65501:ASN | Anteponer ASN par 1x a ASN vecino | |
| RT:65502:ASN | Anteponer ASN par 2x a ASN vecino | |
| RT:65503:ASN | Anteponer ASN de pares 3x a ASN de vecinos | |
| 24115:1:24115 | Política de apertura por defecto | Anunciar a todos los pares |
| 24115:0:24115 | Política cerrada por defecto | No anunciar a ningún compañero |
| 24115:0:ASN | No exportar a ASN | No anunciar al vecino ASN |
| 24115:1:ASN | Permitir la exportación a ASN | Anunciar a ASN vecino |
| 24115:2:MS | No exportar a vecinos por encima de MS | Incremento de 5 ms a 200 ms |
| 24115:101:ASN | Anteponer 1x al ASN vecino | Anteponer AS par a ruta |
| 24115:102:ASN | Anteponer 2x a ASN vecino | Anteponer AS par a ruta |
| 24115:103:ASN | Anteponer 3x al ASN vecino | Anteponer AS par a ruta |
| 24115:111:MS | Anteponer 1x para latencia superior a MS | Incremento de 5 ms a 200 ms |
| 24115:112:MS | Preañada 2x para latencia superior a MS | Incremento de 5 ms a 200 ms |
| 24115:113:MS | Anteponer 3x para latencia superior a MS | Incremento de 5 ms a 200 ms |
Comunidades informativas filtradas (sólo se muestran en Looking Glass en el portal IX)
| Comunidad | Descripción | Notas |
|---|---|---|
| 24115:1101:1 | Longitud del prefijo demasiado larga | Longitud máxima IPv4: 24, IPv6: 64 |
| 24115:1101:2 | Longitud del prefijo demasiado corta | Longitud mínima IPv4: 24, IPv6: 64 (solo RTBH) |
| 24115:1101:3 | Prefijo Bogon | Bogones IPv4 e IPv6 de Cymru |
| 24115:1101:4 | Bogon ASN en ruta | Bogon ASN en ruta |
| 24115:1101:5 | Ruta AS demasiado larga | IPv4: 24, IPv6: 64 |
| 24115:1101:6 | Ruta AS demasiado corta | IPv4: 0, IPv6: 0 |
| 24115:1101:7 | Primer ASN no válido | Primer AS en la ruta no AS par |
| 24115:1101:8 | Dirección de siguiente salto no válida | La dirección Next Hop no es Peer Address |
| 24115:1101:9 | Prefijo IRRDB no encontrado | No se ha encontrado el prefijo en Peer ASN o AS-SET |
| 24115:1101:13 | RPKI no es válido | ROA, AS de origen y/o longitud de prefijo no válidos |
| 24115:1101:20 | Bucle AS | Bucle AS en ruta |
| 24115:1102:1 | Publicidad Peer declina Prefijo | La política de pares anunciantes excluye a los pares receptores |
Ejemplos de configuración utilizando comunidades BGP
Abierto por defecto, excepto con AS10, AS20 y AS30
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-open community on outbound and
# set communities to restrict annoucnements from AS10, 20 and 30.
route-map eqixsg-out permit 10
set community 24115:24115 0:10 0:20 0:30
# reject routes received from AS 10, 20 and 30
route-map eqixsg-in deny 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^30_
Cerrado por defecto, excepto AS10, AS20 y AS100030
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# set default-closed community on outbound and
# set communities on announcements to AS10, AS20, and AS100030
route-map eqixsg-out permit 10
set community 0:24115 24115:10 24115:20 24115:30
set extcommunity rt 0:100030
# accept routes from AS10, AS20, and AS100030
route-map eqixsg-in permit 10
match as-path 10
ip as-path access-list 10 permit ^10_
ip as-path access-list 10 permit ^20_
ip as-path access-list 10 permit ^100030_
Rutas locales a todo el mundo, internacionales a/desde AS10 y AS100020 solamente
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
# announce local routes with default open community
route-map eqixsg-out permit 10
match community 40:4000 # local routes
set community 24115:24115
# announce international routes with default closed community
# and community to announce to AS10 and AS100020 only
route-map eqixsg-out permit 20
match community 40:5000 # international routes
set community 0:24115 24115:10
set extcommunity rt 24115:100020
Anteponer AS40 1x a AS10, 2x a AS20 y 3x a AS100030
router bgp 40
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map eqixsg-in in
neighbor 202.79.197.126 route-map eqixsg-out out
route-map eqixsg-out permit 10
set community 65501:10 65502:20
set extcommunity rt 65503:100030
Agujero negro a distancia
# signals to MLPE route-servers to set next-hop as Black Hole host for configured network/host
router bgp 40
network 1.1.1.1 mask 255.255.255.255
neighbor 202.79.197.126 remote-as 24115
neighbor 202.79.197.126 route-map RM-RTBH-OUT out
neighbor 202.79.197.126 send-community
route-map RM-RTBH-OUT permit 10
match ip address prefix-list PL-RTBH-OUT
set community 65535:666
ip prefix-list PL-RTBH-OUT seq 10 permit 1.1.1.1/32
ip route 1.1.1.1 255.255.255.255 Null0