Sample Configurations
Depending on the type of Equinix Precision Time service that you and your clients use, various PTP and NTP client configuration settings are required.
Equinix PTP Service Configurations
Configuration Parameter | Equinix Provided Configurations | Tool Tip |
---|---|---|
Domain | 30 | PTP domain is a network, or portion of a network, within which PTP operates. Within this network, all the clocks are in sync. |
Log Announce Interval | 1 | Logarithmic value that controls the rate of PTP Announce packets from the PTP time server. Default is 1 (1 packet every 2 seconds). |
Log Delayreq Interval | -4 | Logarithmic value that controls the rate of PTP DelayReq packets. Default is -4 (16 packets per second). |
Log Sync Interval | -4 | Logarithmic value that controls the rate of PTP Sync packets. Default is -4 (16 packets per second). |
Priority1 | 128 | Lower value indicates higher priority. |
Priority2 | 128 | Lower value indicates higher priority. |
Clock Class | 13 | Value that indicates the timescale which delivers UTC timestamps (set by default). |
Clock Accuracy | 23 | Value that indicates how accurate the source is to UTC time. Equinix Time sources are accurate up to 1µs from UTC (set by default). |
Sample Configurations
These sections contain sample configuration code for NTP and PTP clients. The values apply for default Precision Time Service settings.
Sample Configuration – chronyd
server 192.168.1.21 iburst prefer
server 192.168.1.22 iburst prefer
driftfile /path/to/chrony/drift
makestep 1 3
rtcsync
logdir /path/to/log/directory
pidfile /path/to/chrony.pid
log measurements statistics tracking
Sample Configuration – ntpd
The Network Time Protocol daemon (ntpd) is the sample configuration used for NTP client devices.
driftfile /var/lib/ntp/drift
restrict default nomodify notrap nopeer noquery
restrict 127.0.0.1
restrict ::1
server 192.168.1.21 iburst true
server 192.168.1.22 iburst true
includefile /etc/ntp/crypto/pw
keys /etc/ntp/keys
disable monitor
Sample Configuration – ptpd
Similarly, the Precision Time Protocol daemon (ptpd) maintains the system time to synchronize with time servers using PTP.
ptpengine:preset=slaveonly
ptpengine:domain=30
ptpengine:sync_outlier_filter_enable=y
ptpengine:delay_outlier_filter_enable=y
ptpengine:sync_stat_filter_enable=y
ptpengine:delay_stat_filter_enable=y
ptpengine:log_announce_interval=1
ptpengine:log_sync_interval=-4
ptpengine:log_delayreq_interval=-4
ptpengine:calibration_delay=20
ptpengine:hardware_timestamping=y
clock:allow_step_backwards=y
clock:allow_step_backwards_hw=y
global:log_status=y
global:status_file=/path/to/ptp.status
global:log_file=/path/to/ptp.log
global:log_statistics=y
global:statistics_log_interval=0
global:statistics_timestamp_format=both
global:statistics_update_interval=1
global:statistics_file=/path/to/ptp.statistics
global:lock_file=/path/to/ptp.pid
Sample Configuration – ptp4l
The ptp4l tool is an implementation of PTP for Linux.
[global]
twoStepFlag 1
slaveOnly 0
priority1 128
priority2 128
domainNumber 30
logAnnounceInterval 1
logSyncInterval -4
logMinDelayReqInterval -4
tx_timestamp_timeout 100
logging_level 6
Sample Configuration – Arista 7050 Boundary Clock Mode Configuration
This Arista 7050 tool is an implementation of IEEE 1588 PTP for boundary clock. If you are using Arista 7050 for boundary clock mode within the client network, this sample configuration code can be used.
<< Enabling Global PTP configurations on the switch >>
ptp mode boundary
ptp domain 30
ptp source ip 172.16.100.9
<< Slave Port Specific Configuration>>
interface Ethernet47
description ECX::EQIX-EPT-SV5-CX-PRI-03
switchport mode trunk
ptp enable
ptp sync-message interval -4
ptp announce interval 0
ptp delay-req interval -4
ptp vlan 111
Sample Configuration – Arista 7150 Boundary Clock Mode
This is a similar tool, for Arista 7150. If you are using Arista 7150 for boundary clock mode within the client network, this sample configuration code can be used.
<< Slave Port Specific Configuration>>
interface Port-Channel13
switchport trunk allowed vlan 13
switchport mode trunk
ptp enable
ptp sync-message interval -4
ptp announce interval 1
ptp delay-req interval -4
ptp vlan 13
interface Ethernet44
description reserved_PTP
switchport trunk allowed vlan 13
switchport mode trunk
channel-group 13 mode active
ptp enable
ptp vlan 13
<< Enabling Global PTP configurations on the switch >>
ptp domain 30
ptp source ip 10.100.1.209
ptp priority1 129
ptp mode boundary
Sample Configuration – NTP over Anycast Solution using Network Edge
See the Anycast Use Case for details about configuring Network Edge devices, including routers, firewalls, and NTP, over Anycast.